CompletedUpdate cards infrastructure
Status
Resolved after 24 minutes
Started
July 13, 2023 at 5:00 PM
Completed
July 14, 2023 at 4:48 PM
Affects
Mobile Apps
Payment Processing
- CompletedJuly 13, 2023 at 5:23 PM
- In progressJuly 13, 2023 at 5:00 PM
- PlannedJuly 13, 2023 at 5:00 PM