Resolved
0.mxqfjm6zjoxx: Incident with Customer Portal

Started
May 22, 2023 at 2:17 PM
Status
Resolved after 1 minute

Impact

Major outage
Affected
Customer Portal
  • Resolved

    This incident has been resolved.

  • Investigating

    We're experiencing some problems with customer portal availablity. Our team is currently working to restore the service. We apologize for any inconvenience