0.nhv74upw2sd3: Incident with Payment Processing, Onboarding
Resolved
Degraded performance
Started 3 months agoLasted about 2 hours
Affected
Onboarding
Payment Processing
Updates
Resolved
Resolved
This incident has been resolved.
Investigating
Investigating
Some problems reported with payment processing and automated onboarding. Our team is currently working to restore the service. We apologize for any inconvenience